VR Dashboard
Post by iconPost by urbicande | 2020-10-16 | 16:30:53

Hello, for a few days the VR Dashboard extension has stopped working!
Do you have an explanation ?
thank you for the answer

commenticon 44 Comments
Post by iconPost by zezo | 2020-10-16 | 17:04:50
VR changed the game protocol again. But then Michael changed the Dashboard too, so the current version should work. See if you have a manually installed version or restart your browser if it's been running for more than few days.

See the next thread (Jamaica Express Race) for more details.

The fixed version is 3.12.0 or 3.12.1

Post by iconPost by Ventura_317 | 2020-10-17 | 18:44:43
Is Zezo /VR Dashboard / Route Zezo ......... let's say ....disturbing the VR Business ? LOL ?
Post by iconPost by urbicande | 2020-10-16 | 21:44:36
thank you

Post by iconPost by Marty6 | 2020-10-17 | 16:19:11
I don't get the regular updates in the race log for Jamaica with 3.12.1. There are only entries from when i enter the race via the browser app. Restarted browser yesterday.
Post by iconPost by Hardtack | 2020-10-17 | 16:59:15
VR does not send regular updates in Jamaica Express.
You need to wait until the refresh button appears in the game UI and click it if you want a refresh.

Post by iconPost by Marty6 | 2020-10-18 | 01:11:01
Post by iconPost by urbicande | 2020-10-22 | 08:19:39
Hello Since yesterday, again, when starting VR, VR dashboard does not start, red icon, and nothing happens. Thank you for helping me !
Post by iconPost by Hardtack | 2020-10-22 | 12:06:31
Works for me. Can you provide more info? Which race? Did you try to restart your browser? Are you running multiple browser windows?
Post by iconPost by urbicande | 2020-10-22 | 12:14:50
Please help me, I am registered for the next Vendée Globe awaiting the start, I have reloaded the latest version of VR Dasboard and I am following the manual display procedure, when VR opens the Z turns red , and at the choice of the race nothing happens!
VR dashbord remains empty and does not launch ZeZo
Post by iconPost by Hardtack | 2020-10-22 | 12:48:55
Okay, that's actually a frequently asked question and it's not properly answered in the VRDashboard manual.

The reason is, Zezo did not add the race yet.
And the reason for that is, the race is still more than two weeks out. We don't even have weather data for the start of the race!
Post by iconPost by urbicande | 2020-10-22 | 12:57:29
Thank you Hardtack for the answer, I just signed up for the VR Bermuda race that Cvetan just added on Zezo and the same VR Dasboard does not work on my two computers!

Post by iconPost by Hardtack | 2020-10-22 | 15:52:13
Please follow these instructions:
1. Start browser
2. Navigate to virtualregatta.com
3. Activate VRDashboard
4. Log in to VR Offshore
5. Select a race from the VR Offshore landing page

Proper functioning of the Dashboard depends on what messages are sent by VR and when they are sent. I'll eventually try to make things more robust, but for now you need to perform the steps in this exact sequence. In particular, if you swap steps 3 and 4, VRDashboard will not work for the new races.

Post by iconPost by urbicande | 2020-10-22 | 16:12:54
Thanks Hardtack, I followed your instructions, but nothing is happening! VR Dasboard is activated as soon as the VR home page is launched, but remains without any indications even after the launch of the chosen race!
Post by iconPost by urbicande | 2020-10-22 | 16:49:11
Hello Hardtack, VR Dashboard connects automatically without my intervention (Z red) when opening the Virtual Regatta home page, and when launching the game remains empty and nothing happens!
Post by iconPost by urbicande | 2020-10-22 | 16:59:37
Hello Hardtack, everything is working normally now!
Post by iconPost by Eliric | 2020-10-22 | 18:34:27
When using the VR dashboard extension in Chrome (per Hardtack's instructions), the competitors I have in the VR "Following list" are gone ; nobody is there.
So I use Zezo routing entering manually my position without the extension.
I already posted the same at the Bermuda Challenge topic. Any solution?
Post by iconPost by Hardtack | 2020-10-22 | 18:45:51
Fleet display was temporarily broken but should work again since version 3.12.3

Also I don*t understand why you need the Fleet tab to route your own boat?

Post by iconPost by Eliric | 2020-10-23 | 19:51:54
Hello Hardtack.
VR fleet display works now. I am not using the VR Dashboard fleet tab to route my own boat. It was only useful, when the VR navigation panel was not showing the other followed competitors.
Now following your instructions I am able to connect the VR Dashboard with the Chrome extension. Thanks
Post by iconPost by BGSteMarine | 2020-10-22 | 20:56:00
Quite a strange thing on Bermuda : I have put a PROG at 4:00, and when looking at the race log in the dashboard, the boat action is "Actions: TWA=50.0 @ 23/10/2020 à 05:00:00 UTC+2" ...
Post by iconPost by zezo | 2020-10-22 | 20:59:44
Same here. Actual time is 07 UTC. Someone switched DST off already?

Actions: TWA=49.9 @ 10/23/2020, 08:00:00 UTC;

This should not be in the dashboard thread, though. More like the 'endless VR bug report' thread.

Post by iconPost by zezo | 2020-10-22 | 21:28:53
The time actually moves in the UI too if you close and reopen the waypoint list.

The in-game clock is also wrong. It's 0:30 here now, but it shows 23:30.

Post by iconPost by BooBill | 2020-10-22 | 22:27:51
I observed that last night around 0400z. It resolved after maybe 30 minutes.
Post by iconPost by marc07 | 2020-10-23 | 09:45:48
Hello. I have similar issue with VR dashboard: with new race (Bermuda) dashboard is empty and gives this message : Logged-on user is unknown, please exit and re-enter VR Offshore!
With old race (Mauricienne) no issue. (version 3.12.3)
Any idea ?
Post by iconPost by Hardtack | 2020-10-23 | 10:52:39
Did you try to do what it says? And did it help?
Post by iconPost by orev30 | 2020-10-24 | 05:46:45
Hello, I have exactly the same problem since yesterday.Boat unknown...
Post by iconPost by marc07 | 2020-10-23 | 12:18:08
Yes. Solved the issue but once. When openning again the race in VR Offshore home page it leads to same situation. Should I disconnect and re-login each time ?
Post by iconPost by Hardtack | 2020-10-23 | 13:05:06
You shouldn't have to, unless you're changing users.

Post by iconPost by Pimpi | 2020-10-24 | 17:47:43
Hi, why...? What does it happen in this case (changing user)?
Thank you for reading me :)

Post by iconPost by Hardtack | 2020-10-24 | 18:59:30
VR Dashbaord didn't catch the user change and could not handle position updates correctly, raising the above message instead - but it looks like I fixed it 8-)

Post by iconPost by Luis75 | 2020-10-30 | 23:06:22
Hi Hardtack,
I installed version 12.3.7.
When I load virtualregatta.com and click on the extension I receive the following message: "Cannot attach to this target".
What do I do wrong?
Post by iconPost by YourMomSA | 2020-10-31 | 01:26:38
In the past, it worked from VR's main page, but now the main page produces that message. It works if you go into the VR Offshore area and then open Dashboard from there.
Post by iconPost by Hardtack | 2020-10-31 | 02:26:52
Yes, I'm aware of this error. It seems to happen only on Chrome/Linux but maybe it depends on the Chrome version. If you are on Linux, please try Chromium. If you're getting this error on Chrome/Windows, please let me know your browser version.

It should work from the VR main page. Logging in to VR offshore first means you need to start VR Dashboard quickly, otherwise it will miss the message containing your own VR user id.
Post by iconPost by Luis75 | 2020-10-31 | 07:17:03
Thanks Hardtack,
my OS is MacOS Mojave 10.14.6
Chrome version is Version 86.0.4240.111 (Official Build) (x86_64)
If I try to click on the Z immediately after loading VR Offshore, the Z icon switches on and immediately back off.
Do you Maybe have an older version? 12.3.3 used to work...
Post by iconPost by Hardtack | 2020-10-31 | 11:46:23
Okay - I don't have access to a Mac unfortunately, but my Chrome/Linux has the same build number.

Users had reported this error on a previous version in the Chrome Web Store.

In response to this I added the 'activeTab' privilege as the only change in 3.12.7. It fixed the error for me in Chrome. After Google released version 3.12.7 to the web store, the error was back.
It had never occurred in Chromium.

I currently think this is a Chrome bug.

Post by iconPost by GeGaX | 2020-10-31 | 12:37:16
Hi Michael 😉,
If need testing on macOS, I can do it if you want.
macOS Catalina up to date and GChrome up to date too
Post by iconPost by Hardtack | 2020-10-31 | 14:00:22
Sure, feel free to test.
On Chrome/Linux I was able to start the dashboard from the VR home page a couple of times. Bizarrely the error occurred when I was running Chromium at the same time. After several tries the error now always occurs in Chrome. It never occurred in Chromium.
Post by iconPost by urbicande | 2020-10-31 | 12:32:08
Hello Hardtack, for me everything works normally on my two Windows 10 PCs, Chrome and VR Dasboard 3.12.7. !
Post by iconPost by Hardtack | 2020-10-31 | 13:51:04
Thanks, that's good to know.

Post by iconPost by BooBill | 2020-10-31 | 13:32:42
I'm on Mac OS 10.13.6 High Sierra, with Chrome Version 86.0.4240.111 (Official Build) and Dashboard 3.12.7

I've had none of the problems described above in La Mauricienne. However, when the Bermuda race was still on it wouldn't pick up my username, unless I went into Mauricienne and then back to Bermuda.

I always start on the Offshore landing page. Never have had to go back to the VR Home Page.

Post by iconPost by Hardtack | 2020-10-31 | 13:48:51
Here is another workaround:
1. Go to the VR Offshore page first (logging in), start Dashoard.
2. In the VR Offshore tab navigate to the VR home page. Dashboard should continue to run.
3. Log in to VR Offshore again.

Dashboard could pick up your user name in La Mauricienne because that race is running on the old engine. When all races run on the new engine, switching races will no longer help.
Post by iconPost by Luis75 | 2020-11-01 | 12:52:06
Now everything works.
Thank you.
Post by iconPost by SailSmurf - LSV | 2022-03-29 | 13:14:53

The current extension release 3.18.1 will no longer work on Chrome in 2023 (Due the End of Life with Manifest V2). Is there any plan to migrate to Manifest V3 as it is already suppported by chrome?

Very Good Job.

Post by iconPost by Hardtack | 2022-03-31 | 18:54:26
Yes, I saw that. I'm planning to find some time soon.

Post by iconPost by Baker | 2022-04-02 | 15:07:20
I've not been able to have the dashboard working on my Mac for quite a while, today I've tried Chromium (88.0.4311.0) and it's working like a charm. Osx Monterey 12.3
Topics list
Copyright 2009 by ZEZO.ORG. All Rights Reserved.